À-la-carte User Guide

User guide and tutorial for the Antiquity À-la-carte application, version 2.0. Feel free to add any suggestions, comments, or potentially interesting uses in the comments section.

Browser Warning

We strongly recommend that you use Firefox, Chrome, or Safari to interact with the application. Internet Explorer will work for most features, but it is currently incompatible with the software we are using to create .pdf files.

Table of Contents

Basic Navigation
Additional Layer Data
Help and About
Searching for features
Static vs. Interactive Features
Pleiades Static Features
Language Display
Time Periodization
Map Tools
Export, Import, Uploading, and Printing
Interactive Gazetteer
Pop-ups and Feature Editing




Basic Navigation

Upon opening the application, you will be greeted by the main screen of the site which looks like the following:

The screen has two main parts: The Map Panel which houses the map takes up the majority of the application screen, while the Map Controls are presented in a collapsible menu on the right-hand side of the screen. You can adjust the visible map panels by clicking on the various arrows of each panel. These will shrink or expand the corresponding panels. For instance, shrinking all the panels except the map panel will display only the map, as seen in the screen shot below:


This option for shrinking is useful for creating a “final” map for display or printing once all searching and manipulation have been performed. Clicking on a portion of the map and dragging the mouse pans the map. The plus and minus buttons, or a mouse scroll wheel, will increase or decrease the zoom of the map. Alternatively, a double click anywhere on the map will zoom in to that particular spot. You can also adjust the map scale in the drop down menu. To return to the original map zoom, click on the ‘Original Zoom’ button. In the Map Controls section to the right you can add and subtract different map layers from the application by clicking on the check-boxes. In this instance all the layers, including roads and all Pleiades features, are showing.

In the next image, the elevation and hillshade layers have been disabled, creating a very different visual effect:

The user can also adjust the opacity of a particular layer. Choose a layer in the Map Controls panel in the bottom right of the screen and then move the slider to your desired opacity. In this example the ocean has become more transparent:


Additional Layer Data

In addition to the physical landscape, the map also features cultural data presented as selectable layers. Urban areas, aqueducts, and Roman roads are all found under the ‘Physical Culture’ grouping in the map layers list. There is also shading available for different political entities under the ‘Political Areas’ folder found directly under the ‘Physical Culture’ grouping. Click to expand this folder and see what is available. In this example we wish to display the empire of Alexander the Great, so we select the corresponding layer. Different empires are provided with different color schemes, enabling the user to add multiple shaded layers to the same map, should they so choose.


Clicking on the Legend button on the map panel will display a pop-up window with the map legend. This displays all layers currently visible on the map; changing a layer’s visibility will add or remove that layer from the legend as appropriate. The user can scroll down to view the entire legend or expand the window to whatever size you wish.


Help and About

The Help button will display a window that links to this document and the Antiquity À-la-carte main page.

The About button launches a window that explains more about the application, its data, and credits.



Searching for features

A main application of Antiquity À-la-carte is the ability to search for and display cultural data on the map base. This section discusses how to search using the two main search options: by feature information or by geographic location. Clicking on the ‘Search’ button located in the upper right of the Map Controls panel launches the search window, shown below.


The search window has two main elements: The search panel to the left and the search results to the right. The primary method of searching is to enter search information in the search panel. Once the user provided the desired search criteria, the ‘Search’ button in the search window should be selected again (or alternatively press enter to see the results). If the search returns many results, it may take some time for the application to load, so it is a good idea to be as specific as possible. In this instance, we are going to search for any feature with the name “Athens”.  It is possible to search with any capitalization and in any language, but if you search in Greek the accents either have to be correct or omitted entirely. You can also leave out part of the name. For instance, if you cannot remember the ending of a placename (such as Pergamon or Pergamum), you can search for part of the word (Pergam).

The results will appear in the results panel to the right, in addition to the number of results in the lower right-hand portion of the window. In order to sort the results (either ascending or descending), hover over the header row of a column; an arrow will then appear; clicking on the arrow will open a drop-down menu wherein sorting options can be chosen. The drop-down menu also includes an option called ‘Columns’: this allow for the selection of those columns of data which you want to display in your search results. You can even drag the columns to have them display in a different order.


You can double-click on any feature, or highlight it and click the “Add a Feature to Map” button to create an interactive feature on the map. You will now see Athens placed on the map, and the map will recenter itself to the feature that was just added. For finding multiple locations that share a name (or a part of a name), the process is much the same. In this next example we will locate places that reflect Alexander anywhere in their names. So we simply enter ‘Alexand’ in the name box of the Search field top left. For searching alexand we have 37 results, as seen in the image below:

If we then want our map to show all these places that reflect Alexander in their name, we can do that by clicking the ‘Add all’ button at the bottom of the Results panel. N.B. that doing so with a large number of results at once (~100) may slow the performance of the application (especially on less powerful computers), as the underlying software of Openlayers has difficulty displaying many features simultaneously.




You will notice that many of these places do not, in fact, include alexand in their names as they appear on the map. However, examining a place in the Results or Features panels, the column ‘search name’ will show what name the application matched with the search. Do this for Bagram, for instance, and see that it is also referred to as Alexandria; hence, Bagram has been marked on the map.

You can also search by type (fort, settlement, lake, etc), or by time period [as in the Barrington Atlas: A = archaic, C = classical, H = Hellenistic, R = Roman, L = Late Antique), Pleiades ID number, or a geographic location expressed in geojson format (explained below) You can leave any of these search boxes blank, or fill them simultaneously for a more refined search. For instance, in the example below we are searching for any forts that have the name portus: three results are returned.


The other method of searching for features is to draw a polygon search area and then return the results. If you click on the "Draw Search Area" button on the search panel, you will notice that the window disappears and the cursor changes into a blue dot.

A single click places a vertex and then allows you to continue to another vertex until you have completed the polygon. Double clicking finalizes the polygon and returns all of the features enclosed in that area. In this example, we are drawing a polygon around Crete:

After finalizing the polygon, the search window will reappear, with the Geometry section filled in.

From here you can refine your results further by setting additional values in the search window and clicking on the "Search" button. In this example we will refine our search to show temples, which yields results in our geographical area. You can add whatever results you wish to the map in the same manner as described above.

Static vs. Interactive Features

Static features allow you to view many different features at once, but do not allow for manipulation or extensive user interaction and do not appear on map gazetteer, .csv, .json, or .kml exports (but they do appear in an exported .pdf). Interactive features allow for dragging and editing, and appear on all map exports. This distinction is a result of the software used to build the application, which has a restriction on the number of interactive features that can be shown at once.

Static features are useful for displaying all of the Pleiades dataset at once, or for conducting Pleiades edits using the Antiquity À-la-carte application as the interface. Interactive features allow for extensive map customization and are created by adding features from a search, importing .json files, or by creating your own features.


Pleiades Static Features

You can display all of the features in the Pleiades dataset by selecting the 'Static Features' or 'Static Features, Scaled' boxes in the Map Layers list on the right. The 'Static Features' will display ALL of the Pleiades features at all zoom levels, while the  'Static Features, Scaled' will show 'important' features (as chosen by the AWMC) at every zoom level and place additional features as you zoom in on the map. Additionally, you can label all of these features by clicking on the Static Labels box and zooming in. These labels are scaled similarly to the 'Static Features, Scaled'  layer.

Clicking on a static feature (with or without the labels) will generate a popup listing any features in that location. As there are often multiple features in a particular coordinate point in Pleiades, you may see one or many results for a particular location, as shown in the example below.

You can then select a particular location which will generate an informational pop-up. This pop-up behaves exactly like the one explained below, with the exception that the tools panel is missing and any edits will have no effect unless the feature is added as an interactive feature.

You can close this pop-up or click on the Make Interactive Feature button to add a manipulable feature to the map. A manipulable feature allows you to change the name, labels, location, and any other feature information. If you wish to make edits, click on the OK button when you are finished to save your work.

Language Display

You can choose to display a map with names of features in English, Greek, or Latin, or numbered; alternatively, you can opt to omit all names. You can also view custom names or the title provided by the Pleiades data set. In the toolbar immediately above the map, click 'Labels', and then in the pop-up menu click on your choice. ‘Map Numbers’ will show a number for every feature displayed on the map. Whenever you have added, deleted, hidden, or restored previously hidden features, click on this button again, and there will be a (re)numbering of all the features now displayed on the map.

Time Periodization

Click Time Period(s) in the toolbar immediately above the map. Features in all five time periods are automatically shown. But if you would like the map not to reflect as many as four of the five, click on the tick box to the left of the relevant period name(s) in the menu. As soon as you have clicked on one tick box in this way, the menu will close, and features for that period will disappear from the map. Should you wish the map not to reflect further time period(s), you must then repeat these steps for each such period. The same applies if you wish to restore display of a time period’s features.

Map Tools

Beyond searching for features and displaying them, there are other map tools at the user's disposal. Many of are located in the toolbar immediately above the map panel: click on Map Tools for a menu to appear.

Let’s proceed through the Tools menu. Here you are offered seven options, only one of which can be in use at any one time.

The default tool (set automatically) is 'Select Feature / Navigate'. This allows for map panning / zooming, and for the selection of features for an information popup. Bear in mind that after you have been using any other tool in the menu and want to make this one your choice again, you have to select it again yourself; it is not automatically reset.

Second in the menu is the 'Measure' tool, which allows you to calculate any distance on the map. When you click on this tool, your cursor on the map will change to an blue circle. Click on the map to begin your measurement and double click to end it.

Double clicking will show a pop-up on your screen that gives the distance in kilometers. Once you have made a note of this information, you can remove the pop-up by clicking ‘Close’.

You can also single-click to continue a measurement in a different direction. This is useful for measuring roads, coasts, or any distance that is not a simple straight line. Up reaching the of whatever feature you want to measure, double-click (as above) to display the total distance traversed.

Third is the 'drag feature' tool. It allows you to relocate any Interactive feature on the map (including line work and polygons, which will be discussed below). Select this tool, then click on whatever feature you want to move, hold down the mouse button, then move the feature to wherever you wish on the map. As an example, we’ll drag Alexandrou Parembole from Egypt to Cyprus.

After dragging, simply release the mouse button to finalize the move.

Fourth, the 'Draw Feature' tool allows you to place a new specific point on the map. Select this tool, move the cursor to where you want to place the new feature, and then click the mouse button. An information box will then appear. In it you must choose a 'Feature Type' from the drop down menu. You can, if you wish, enter an English, Greek, or Latin name for the feature. For any feature’s time period, ACHRL(*****) is set as the default, but you can change this as required; you must, however, specify at least one period (e.g. H, or L), because otherwise the new feature will not display. For the feature’s latitude and longitude, the figures for the location where you have placed the feature will display automatically. If you are in possession of precise co-ordinates which your placement of the feature has not quite achieved, change the figure(s) and the placement of the feature will be shifted accordingly. Once you have made all your choices, hit ‘OK’. In this example we will add a fort, specifying its time period to be HRL:

Then you can see the new feature on the map:

The fifth tool allows for the creation of line work such as roads, walls, travel itineraries, etc. Clicking on the 'Draw Line Work' option changes your cursor to a circle and allows for manipulation in the same manner as the measurement tool. When drawing, a single-click continues the line in a different direction. Once done, double-click to finalize the line.  Just as with the 'Draw Feature' tool, a box will then appear allowing you to name your line, to select what type it is, and to specify its time period(s). Here, too, the naming is optional, but you must specify a type and time period(s). In this case we’ve decided to create a road:

Clicking OK will create the road as a feature on the map.

The sixth tool is 'Draw Polygon Areas'. It creates closed shapes (solid or transparent) on the map, such as urban centers or inland water features, or limits of political control, social movements, etc. Just as with the 'Measure' and 'Draw Feature' tools, a single-click places a vertex and then allows you to continue to another vertex until you have completed the polygon. Double-clicking finalizes the polygon.

Again a box will appear, allowing you to select the various attributes of the polygon. At the minimum, you must select type and time period(s).

Once done, hit the ‘OK’ button.

In general, if you are not adding any new features, it is always best to have the 'Select Feature / Navigate' tool active.


Export, Import, Uploading and Printing

The user has several different options when it comes to saving a map, all of which are found in the File menu in the map toolbar.

Under the export option you can export all the features in the map to a .csv, .json or .kml file which will be downloaded by your computer. The .csv file can be opened in Microsoft Excel, OpenOffice, or any other general text editor. The .json file has all of the feature information in a format suitable for many applications, and it can be directly read by QGIS. The .kml file can be directly imported into Google Earth.

If you export your map as a .json file, you can upload it into the application for use at a different time. In this example, we hace created a map that features all the different places that have "Alexandria" as a name.

We now export the map by selecting File -> export -> export as .json. Your browser should prompt you to save the file .

We are now going to refresh the page. You will notice that all of the features have vanished.

Now we will go to File -> Upload which will launch a pop-up window.

Click on the Browse button to find your .json file, then click on the upload button to add it to the map. You will notice a status bar that indicates the application is uploading and processing your file; as soon as it is finished the window will close and an informational pop-up will appear which informs you of the success of your upload. Click 'OK' and you will see the features added to the map.

You can export your map to a .pdf file suitable for printing by clicking on File -> print. This launches a pop-up window and an interactive orange box that represents the area to be printed.

You can increase or decrease the size of the box, move it around the map, and even rotate it by manipulating the blue circles on it. Please note that the proportions of the printed areas are fixed, so your choices are automatically limited to the area that can be printed. When you are satisfied with the print area, you can add optional comments and an optional title in the popup window, then click Print to launch the .pdf creation. You will then notice a status bar that indicates the system is working; your file should then download locally after the system process the data.

You will notice that any interactive features on the .pdf will look slightly different than what appears on your screen, which is a function of the different software components that stitch this application together. However, you can edit the resulting .pdf in Inkscape, Adobe Illustrator, or other software programs to further manipulate and stylize the font size, position, and any other visual components of interactive features. While styles may be edited, no editing of the base layer is possible.


Interactive Gazetteer

Clicking on the Interactive Gazetteer button in the map panel tool bar will launch the map gazetteer. This window shows all of the features on the map as well as providing different display options for each feature. Double-clicking on a feature will zoom the map to that location, open an informational pop-up, and close the gazetteer.

You can change the display of a feature by clicking on the Hide / Show Feature buttons. First, you must highlight the relevant feature, then press Hide / Show Features, and whatever you have highlighted will either disappear or reappear. If you click on the Hide All Features button, then all of the features on the map will disappear. If you click the Show All Features button, then all the features on the map will be displayed (including any specific ones that you had previously hidden). If you select a feature and click on Delete Feature, that feature (including any edits of it) will be removed from the map. The Delete All Features button – a serious option to exercise ! – really will remove ALL features and edits from the map. The Number Map Features button will generate a sequential list of numbers for every non hidden feature on the map, useful for cresting map lists.

Finally, the Export Grid button will generate a .csv file of the Gazetteer, including custom names and map numbers (if they were added). This is a quick and efficient means to create a detailed map or  map quiz used in conjunction with a print out of numbered features on the map itself.


Pop-ups and Feature Editing

You can readily edit any features on the map - simply click on a feature on the map itself. A pop-up will then appear allowing you to edit whatever information (name, type, period, external links) that you wish. Once done, click ‘OK’ to save your edits. Alternatively, clicking ‘Cancel’ will restore whatever was in the box when you began your editing. If you export your map, any saved edits will be in the exported file, but your changes will never be saved to A-La-Carte’s database. Therefore your changes will not show on the map if you visit Antiquity à la Carte in the future. The other popup tabs have different features which are explained below.

If you click on the 'Names' tab, the window will display all of the names for a feature that appear in the AWMC database. You can double-click any name to set that as the custom name, which will then appear if that label option is selected in the main map.

The 'Explore Further' tab provides different options for features that appear in the Pleiades dataset. Clicking on the Pleiades button will take you to the Pleiades entry for the feature, where you can submit any additions or corrections to the underlying data of the feature. The Pelagios button will take you to a page that displays all entries for that location in the Pelagios linked data network; finally, the Flickr button will take you to a Flickr page for all pictures tagged with that particular Pleiades ID.

The last tab is labeled 'Tools'. At the moment the only tool available is 'Delete Feature', which will remove that feature from the map (you can add it later by searching for it again).


Linking to the Map

We have an entire page devoted to the process of linking to a completed  À-la-carte map. [Click here to go to the page]



9 responses to À-la-carte User Guide

  1. Kindly inform whether this application is only meant for navigating the cultural information of Pleiades only or other parts of world like Indian Himalayas

    • Hello Vinod,

      Broadly speaking our application is focused on the Ancient Mediterranean, with cultural data from Pleiades and geographical data, physical data, and cultural data generated by the center. There is no reason that you could not use the application to create a map of the Indian Himalayas (or any other region covered by the base map), especially if you provide the cultural information yourself.

      I would encourage you, if you do have data / information that is broadly within the temporal parameters of Pleiades, (roughly 700 BCE to 800 CE, give or take a century…) to contact them about contributing data to the project. If not, there are a lot of other avenues to pursue to getting data published / linked up, which we are happy to discuss over e-mail.

  2. Can I create my own data sets?

    • Hello Louis,

      You certainly can- just add a place by going to the Map Tools menu and select “Draw Feature”. You can then place a new point (or polygons or line work) anywhere on the map and you can then export it (as .kml, .json, .csv) for use later (you can import your data set once it is exported back into the application). We currently do not have a mechanism for importing other preexisting datasets wholesale but if this is a feature that users would like to have we can work on implementing it.

  3. Dear Ryan,

    I’ve only found out about the fascinating opportunities of working with the Antiquity-map yesterday and today I’ve been creating a first map for my current PhD-research (data saved in .json-format). Having read the user guide, it should be easy to print the map; however, the abovementioned File -> print link does not appear in my screen. I hope you can help me out, and keep up this wonderful work!!


    • Hello,

      We are still working on getting the print server up in a reliable manner (our install of MapFish does not seem to be working reliably with the rest of our software). We will try to reenable that feature this week, although it still may be a bit buggy.

  4. Hi,

    Is it possible to manipulate the labels—change the font, size, position, etc.? The labels are so small as to be illegible on the map I am working on, and labels overlap for features that are close to one another (a city and her port, for instance).


    • Hello Thomas,

      So far that is not possible with the code base we are using (labeling in OpenLayers, at least from an end-user perspective, is not something that has received a lot of attention from the developers.) We are trying to write some code in the next version that will allow people to do this by hacking around the limitations that are in place. In the meantime, you could export what you are working on and then import it into QGIS, Adobe Illustrator, or InkScape (try using the file -> print option in the program to generate an editable pdf, from which you can change label fonts, etc).

Leave a reply

You must be logged in to post a comment.